Lightroom Performance Problems

I am not too happy with the performance of Adobe Lightroom 1.2 right now. On Saturday I imported another set of 2,400 photos to be sorted and edited. For some strange reason the performance while developing the photo is completely down the drain:

  • It now takes ages to open the 1:1 view of photo
  • It also takes ages to switch back to “Fit” view of the same photo
  • It takes ages to switch to another photo
  • It takes ages for the controls to react
  • Even when idle, Lightroom consumes 35%-45% CPU power
  • The hard disk LED is flashing like mad, even when idle
  • The swap file is between 850 and 950 GB even when idle

In short: Lightroom is slow as hell, and it is dragging down the whole computer…

Lightroom Performance while idle

And I am pretty sure it is Lightroom that is causing the problems, as the task manager is naming Lightroom as the responsible process. I did a full defrag yesterday to cure the problems, but it did not help.

However, after taking the screenshot above I opened Photoshop to crop and save the image, and guess what? Lightroom immediately stopped behaving like mad, all of a sudden consuming virtually no CPU power when idle, just as it should be. Whatever launching Photoshop did – it was good for Lightroom and stopped the strange behaviour.

On the official support forum, some say that the enabling the “auto write” feature may be responsible for a performance loss. I guess it should not be a big performance drop, because all Lightroom has to do is open the respective XMP file, skip to the end of the file, write the next action to it, and save it. And we are talking about small files, not megabytes of data as with image files. Honestly, with the Lightroom database being not as solid as it should be, I prefer to have my work saved upon developing the image using “auto write”. I think it’s far too risky to rely on the Lightroom database to keep all that crucial data.

So, let’s all hope for the next release of Lightroom to cure some of the issues. In the meantime, I am seriously considering to go “all Mac” and switch to Apple Aperture for image processing. I am getting somewhat tired waiting for Adobe to fix Lightroom.

2 Responses to “Lightroom Performance Problems”

  1. Joe Barrett says:

    Try turning off “Automatically write changes into XMP” under the Catalog preferences. The slow down was supposed to be fixed in version 1.2 but it is still a problem on the Mac version. Turning off this check box for day to day stuff works for me.

    I have a Tip about this also on my site.

    Joe Barrett
    The Image-Space
    http://www.image-space.com

  2. admin says:

    Joe,

    I read about this “fix” at the official Adobe Support Forum. But I think, this is not a good solution.

    By turning off “Automatically write changes into XMP” I put all my eggs into one basket, i.e. the Lightroom database. As this gets easily and frequently corrupted, I am not willing to take this risk. Just imagine your database gets corrupted… Hours and hours of work lost!

    Nah, that’s too risky.